<!DOCTYPE html>
<!--[if lt IE 7 ]><html class="ie ie6 no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7 ]><html class="ie ie7 no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8 ]><html class="ie ie8 no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--><html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-7524911656295831",
    enable_page_level_ads: true
  });
</script>
	
	<!-- Basic Page Needs
  ================================================== -->
	<meta charset="utf-8">
    
    <meta http-equiv="X-UA-Compatible" content="IE=Edge"/> 
	<!-- Mobile Specific Metas
  ================================================== -->
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0"/> 

	<!--[if lt IE 9]>
    <script src="http://www.monroviaweekly.com/wp-content/themes/citynews/js/html5shiv.js" type="text/javascript"></script>
    <![endif]-->

    <title>Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#039; - Monrovia Weekly</title>
<link rel="stylesheet" id="wp-forecast-css" href="http://www.monroviaweekly.com/wp-content/plugins/wp-forecast/wp-forecast-default.css" type="text/css" media="screen" />

<!-- This site is optimized with the Yoast SEO plugin v4.9 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="For the 41st Assembly District’s 2017 “Veteran of the Year,” Assembly member Chris Holden has chosen to honor Monrovia Councilmember Larry J. Spicer,"/>
<link rel="canonical" href="http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#039; - Monrovia Weekly" />
<meta property="og:description" content="For the 41st Assembly District’s 2017 “Veteran of the Year,” Assembly member Chris Holden has chosen to honor Monrovia Councilmember Larry J. Spicer," />
<meta property="og:url" content="http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" />
<meta property="og:site_name" content="Monrovia Weekly" />
<meta property="article:publisher" content="https://www.facebook.com/MonroviaWeekly/" />
<meta property="article:section" content="Community" />
<meta property="article:published_time" content="2017-06-23T06:00:15+00:00" />
<meta property="article:modified_time" content="2017-06-21T14:45:38+00:00" />
<meta property="og:updated_time" content="2017-06-21T14:45:38+00:00" />
<meta property="og:image" content="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer.jpg" />
<meta property="og:image:width" content="4176" />
<meta property="og:image:height" content="2784" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="For the 41st Assembly District’s 2017 “Veteran of the Year,” Assembly member Chris Holden has chosen to honor Monrovia Councilmember Larry J. Spicer," />
<meta name="twitter:title" content="Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#039; - Monrovia Weekly" />
<meta name="twitter:site" content="@monroviaweekly" />
<meta name="twitter:image" content="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer.jpg" />
<meta name="twitter:creator" content="@monroviaweekly" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Monrovia Weekly &raquo; Feed" href="http://www.monroviaweekly.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Monrovia Weekly &raquo; Comments Feed" href="http://www.monroviaweekly.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Monrovia Weekly &raquo; Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#8217; Comments Feed" href="http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/feed/" />
<!-- This site is powered by Shareaholic - https://shareaholic.com -->
<script type='text/javascript' data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"http:\/\/www.monroviaweekly.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","share_counts_url":"http:\/\/www.monroviaweekly.com\/wp-admin\/admin-ajax.php?action=shareaholic_share_counts_api"}};
  //]]>
</script>
<script type='text/javascript' data-cfasync='false'
        src='//dsms0mj1bbhn4.cloudfront.net/assets/pub/shareaholic.js'
        data-shr-siteid='8fbb6f0f318f31e00dd3473c9f0a24ae' async='async' >
</script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='Monrovia Weekly' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/' />
<meta name='shareaholic:keywords' content='veteran, community' />
<meta name='shareaholic:article_published_time' content='2017-06-23T13:00:15+00:00' />
<meta name='shareaholic:article_modified_time' content='2017-06-23T13:00:15+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Monrovia Weekly' />
<meta name='shareaholic:site_id' content='8fbb6f0f318f31e00dd3473c9f0a24ae' />
<meta name='shareaholic:wp_version' content='7.8.0.6' />
<meta name='shareaholic:image' content='http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer-500x333.jpg' />
<!-- Shareaholic Content Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.monroviaweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css'  href='http://www.monroviaweekly.com/wp-includes/css/dashicons.min.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='http://www.monroviaweekly.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.10.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.monroviaweekly.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='http://www.monroviaweekly.com/wp-content/plugins/ditty-news-ticker/assets/fontastic/styles.css?ver=2.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='http://www.monroviaweekly.com/wp-content/plugins/ditty-news-ticker/assets/css/style.css?ver=2.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-widget-css-css'  href='http://www.monroviaweekly.com/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='http://www.monroviaweekly.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_icons-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='social-widget-css'  href='http://www.monroviaweekly.com/wp-content/plugins/social-media-widget/social_widget.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-style-css'  href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/ui-darkness/jquery-ui.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-email-css'  href='http://www.monroviaweekly.com/wp-content/plugins/wp-email/email-css.css?ver=2.67.5' type='text/css' media='all' />
<link rel='stylesheet' id='chosen-css'  href='http://www.monroviaweekly.com/wp-content/plugins/wp-job-manager/assets/css/chosen.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-job-manager-frontend-css'  href='http://www.monroviaweekly.com/wp-content/plugins/wp-job-manager/assets/css/frontend.css?ver=1.26.2' type='text/css' media='all' />
<link rel='stylesheet' id='et-gf-open-sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='et_bloom-css-css'  href='http://www.monroviaweekly.com/wp-content/plugins/bloom/css/style.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='tt-easy-google-fonts-css'  href='http://fonts.googleapis.com/css?family=Source+Sans+Pro%3Aregular&#038;subset=latin%2Call&#038;ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='http://www.monroviaweekly.com/wp-content/themes/Monrovia%20Weekly%20Child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='skeleton1200-css'  href='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/css/skeleton1200.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-reset-css'  href='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/css/reset.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-main-css'  href='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/css/main.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-javascript-css'  href='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/css/javascript.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-responsive-css'  href='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/css/responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/css/font-awesome/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-custom-css'  href='http://www.monroviaweekly.com/wp-content/themes/citynews/custom.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-default-fonts-css'  href='https://fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C600%2C700%2C900%2C400italic%2C600italic%2C700italic%2C900italic%7CPT+Serif%3A400%2C700%2C400italic%2C700italic%7CRoboto+Slab%3A400%2C700%2C300%2C100%7CVoltaire&#038;subset=latin%2Clatin-ext%2Cvietnamese%2Ccyrillic-ext%2Ccyrillic%2Cgreek%2Cgreek-ext' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-addon-css'  href='http://www.monroviaweekly.com/wp-content/plugins/citynews-addon/assets/css/citynews-addon.css' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='http://www.monroviaweekly.com/wp-content/themes/Monrovia%20Weekly%20Child/style.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='cp-perfect-scroll-style-css'  href='http://www.monroviaweekly.com/wp-content/plugins/convertplug/modules/slide_in/../../admin/assets/css/perfect-scrollbar.min.css?ver=4.7.5' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var slide_in = {"demo_dir":"http:\/\/www.monroviaweekly.com\/wp-content\/plugins\/convertplug\/modules\/slide_in\/assets\/demos"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/wp-forecast/wpf_update.js?ver=9999'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var s2_script_strings = {"ajaxurl":"http:\/\/www.monroviaweekly.com\/wp-admin\/admin-ajax.php","title":"Subscribe to this blog"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/subscribe2/include/s2_ajax.min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/modernizr.custom.41385.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jflickrfeed.min.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.colorbox.js'></script>
<link rel='https://api.w.org/' href='http://www.monroviaweekly.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.monroviaweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.monroviaweekly.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.5" />
<link rel='shortlink' href='http://www.monroviaweekly.com/?p=37793' />
<link rel="alternate" type="application/json+oembed" href="http://www.monroviaweekly.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.monroviaweekly.com%2Fcommunity%2Fmonrovian-larry-spicer-named-41st-assembly-districts-veteran-year%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.monroviaweekly.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.monroviaweekly.com%2Fcommunity%2Fmonrovian-larry-spicer-named-41st-assembly-districts-veteran-year%2F&#038;format=xml" />
<style></style><meta property="og:site_name" content="Monrovia Weekly" />
<meta property="og:type" content="website" />
<meta property="og:image" content="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer.jpg" />
<meta property="og:title" content="Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year’" />
<meta property="og:url" content="http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" />
<style type="text/css">
/*Custom CSS*/
#topbar .social_icons {
    max-width: 500px;
    float: right;
    margin-right: 20px;
    margin-top: 0;
}

.single #top {
    margin-bottom: 45px;
}

@media only screen and (max-width: 767px) {
  .logo a span{
    padding:0;
  }
  
  .logo a span img {
      width:100%;
     height:auto !important;
  }
 
 .post.thumbnail_s .thumbnail{
    height:180px;
 }
 .vc_col-sm-3 .post.thumbnail_s .thumbnail img, 
 .vc_col-sm-4 .post.thumbnail_s .thumbnail img{
    max-width:120%;
 }
}
 @media only screen and (max-width: 959px){
.entry-content img {
    max-width: 35%;
    position: relative;
    z-index: 3;
}
/*.logo a span img{
    width:100%;
     height:auto;
}*/
}
.wp-caption-text {
    font-size: 12px;
    font-style: italic;
    line-height: 1;
    margin: 0;
    width: 100%;
    height: auto;
}

@media only screen and (max-width: 959px){
    .wp-caption .wp-caption-text {
    /* padding-right: 10px; */
    width: 296px;
}
}

.vc_general.vc_btn3 {
    line-height: 0;
    font-family: sans-serif;
}

.wpb_content_element {
    /* margin-bottom: 35px; */
    /*height: 230px;*/
}

.entry-content p {
    line-height: 1.5em;
    font-family: sans-serif;
}

p {
    margin-bottom: 1.5em;
}

hr {
    margin-top: 3rem;
    margin-bottom: 3.5rem;
    border-width: 0;
    border-top: 1px solid #3e3944;
}

.shrinked#top .logo{display:none;}
.shrinked #primary_menu ul li{padding:10px 2px;}
.shrinked #primary_menu &gt; ul &gt; li:after{margin-left:5px;}
.shrinked #primary_menu{margin: auto;float: none;width: 93%;
}

.logo a span img {
    height: auto !important;
}

.cn-slider-container .swiper-slide {
    background-position: center top;
}
</style>

<style type="text/css">
a:active,
a:hover,
#primary_menu ul li.current-menu-item a,
#primary_menu ul li a:hover,
#breadcrumbs .goback:hover,
.channel .channel_title a,
.post .entry-title a:hover,
.post .entry-tools a:hover,
.post_list li a.post_title:hover,
#popup_window h3 a,
.entry-content a,
.comment-author a:hover,  
.comment-list .pingback a:hover,  
.comment-list .trackback a:hover,  
.comment-metadata a:hover{
	color:#428c05;
}
.channel .channel_title a,
.tagcloud a:hover,
#popup_window .language_list li a:hover,
#popup_window .dashboard_items li a:hover,
.alaya_pagenavi span,
.alaya_pagenavi a.page:hover,
.contact-form input[type="submit"],
#topbar #tools a:hover,
.button.button-primary,
button.button-primary,
input[type="submit"].button-primary,
input[type="reset"].button-primary,
input[type="button"].button-primary{
    border-color:#428c05;
}
.post_slider.flexslider .flex-control-paging li a.flex-active,
.post.sticky .sign,
.alaya_pagenavi span,
.alaya_pagenavi a.page:hover,
#respond input[type="submit"],
.contact-form input[type="submit"],
#topbar #tools a:hover,
.button.button-primary,
button.button-primary,
input[type="submit"].button-primary,
input[type="reset"].button-primary,
input[type="button"].button-primary{
	background-color:#428c05;
}




</style>

		<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://www.monroviaweekly.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->
<!-- BEGIN GADWP v5.0.1 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-9285716-2', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
		<style type="text/css" id="wp-custom-css">
			cn-slider-container .swiper-slide {n    cursor: -webkit-grab;n    background-size: cover;n    background-position: center top;n}		</style>
	<style id="tt-easy-google-font-styles" type="text/css">p { }
h1 { }
h2 { }
h3 { }
h4 { }
h5 { font-family: 'Source Sans Pro'; font-style: normal; font-weight: 400; }
h6 { font-family: 'Source Sans Pro'; font-style: normal; font-weight: 400; }
 { }
</style><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="post-template-default single single-post postid-37793 single-format-standard et_bloom monrovia-weekly wpb-js-composer js-comp-ver-5.1 vc_responsive">
 
<!-- Pushy Menu -->
<nav class="pushy pushy-left">
    <ul>
        <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-21117"><a href="http://www.monroviaweekly.com/category/current-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-21106"><a href="http://www.monroviaweekly.com/category/current-news/crime/">Crime</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26085"><a href="http://www.monroviaweekly.com/category/current-news/police-blotters/">Blotters</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-21105"><a href="http://www.monroviaweekly.com/category/business/">Business</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36797"><a href="http://www.monroviaweekly.com/category/business/business-profile/">Business Spotlight</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21107"><a href="http://www.monroviaweekly.com/category/school-and-education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21110"><a href="http://www.monroviaweekly.com/category/entertainment/">Arts &#038; Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21122"><a href="http://www.monroviaweekly.com/category/sports-entertainment/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36800"><a href="http://www.monroviaweekly.com/category/calendar/">calendar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36803"><a href="http://www.monroviaweekly.com/category/millennial-feed/">Millennial Feed</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-36801"><a href="http://www.monroviaweekly.com/category/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21112"><a href="http://www.monroviaweekly.com/category/lifestyle/dining-delights/">Dining Delights</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36802"><a href="http://www.monroviaweekly.com/category/lifestyle/travel/">Travel</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26089"><a href="http://www.monroviaweekly.com/category/lifestyle/health-fitness/">Health &#038; Fitness</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-36805"><a href="http://www.monroviaweekly.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36806"><a href="http://www.monroviaweekly.com/category/opinion/columns/">Columns</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36807"><a href="http://www.monroviaweekly.com/category/opinion/letter-to-the-editor/">Letters to the Editor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-36808"><a href="http://www.monroviaweekly.com/category/community/">Community</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21118"><a href="http://www.monroviaweekly.com/category/obituaries/">Obituaries</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36809"><a href="http://www.monroviaweekly.com/category/special-sections/">Special Sections</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36804"><a href="http://local.beaconmedianews.com/">Neighborhood Ads</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37158"><a href="https://www.indeed.com/jobs?q=&#038;l=Monrovia%2C+CA&#038;radius=0">Local Jobs</a></li>
    </ul>
</nav>

<!-- Site Overlay -->
<div class="site-overlay"></div> 
 <div id="body-container">
      <!--Top Bar-->
      <div id="topbar">
           <!--Social Icons-->
	       <div class="social_icons">
		       <div class="social-icons clearfix">
</div>
		   </div>
		   <!--Menu button-->
           <div class="menu_button hide"><a href="javascript:void(0)"><i class="fa fa-bars"></i></a></div>
           
	       <!--Tools-->
		   <div id="tools">
			 
						   <a href="javascript:void(0);" class="search_btn"><i class="fa fa-search"></i></a>
			 			 
			 		   
		   </div> 
      </div> 
           
	        <header id="top">
	      <!--LOGO-->
	      <div class="logo">
	        <a href="http://www.monroviaweekly.com/" title="Monrovia Weekly">
	        	          <span><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/05/Morovia_Weekly-masthead-web.jpg" /></span>
	        	        </a>
	        <div class="local_info">
	          <span class="local_date">Friday, June 23, 2017 </span>
	          	            <span id="weather"></span>
	      	  		   </div>
	      </div>
	      
	      <!--Primary Menu-->
	      <nav id="primary_menu">
		     <ul class="sf-menu">
			   <li id="menu-item-21117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.monroviaweekly.com/category/current-news/">News</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/current-news/crime/couple-outstanding-arrest-warrants-nabbed-auto-burglary-arcadia/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Beyers-Duarte-e1498175031175.jpg" alt="Couple With Outstanding Arrest Warrants Nabbed for Auto Burglary in Arcadia" width="320" height="192" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/current-news/crime/couple-outstanding-arrest-warrants-nabbed-auto-burglary-arcadia/">Couple With Outstanding Arrest Warrants Nabbed for Auto Burglary in Arcadia</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/current-news/monrovia-community-media-foothills-continue-managing-kgem-now/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Joey-Delgado_Miller-1-350x527.jpg" alt="Monrovia Community Media of the Foothills to Continue Managing KGEM, For Now" width="350" height="527" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/current-news/monrovia-community-media-foothills-continue-managing-kgem-now/">Monrovia Community Media of the Foothills to Continue Managing KGEM, For Now</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/current-news/crime/transit-police-may-thwarted-major-violent-incident/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/1-9-350x263.jpg" alt="Transit Police May Have Thwarted a Major Violent Incident" width="350" height="263" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/current-news/crime/transit-police-may-thwarted-major-violent-incident/">Transit Police May Have Thwarted a Major Violent Incident</a></h6>
								</li></ul>
<ul class="sub-menu">
	<li id="menu-item-21106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.monroviaweekly.com/category/current-news/crime/">Crime</a>
	<ul class="sub-menu">
		<li id="menu-item-26085" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/current-news/police-blotters/">Blotters</a></li>
	</ul>
</li>
</ul>
</div>
</li>
<li id="menu-item-21105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.monroviaweekly.com/category/business/">Business</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/business/small-business-committee-approves-rep-chu-bill-to-increase-small-business-investment/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Judy-Chu-1024x680-350x232.jpg" alt="Small Business Committee Approves Rep. Chu Bill to Increase Small Business Investment" width="350" height="232" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/business/small-business-committee-approves-rep-chu-bill-to-increase-small-business-investment/">Small Business Committee Approves Rep. Chu Bill to Increase Small Business Investment</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/business/business-profile/culinary-collaboration-harlowes-french-dip/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/1-64-350x233.jpg" alt="Culinary Collaboration: Harlowe’s French Dip" width="350" height="233" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/business/business-profile/culinary-collaboration-harlowes-french-dip/">Culinary Collaboration: Harlowe’s French Dip</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/opinion/columns/smart-women-smart-money-61517-issue/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/broken-piggy-bank-1472485404YoO-1024x683-350x233.jpg" alt="Smart Women, Smart Money (6/15/17 Issue)" width="350" height="233" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/opinion/columns/smart-women-smart-money-61517-issue/">Smart Women, Smart Money (6/15/17 Issue)</a></h6>
								</li></ul>
<ul class="sub-menu">
	<li id="menu-item-36797" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/business/business-profile/">Business Spotlight</a></li>
</ul>
</div>
</li>
<li id="menu-item-21107" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/school-and-education/">Education</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/school-and-education/portantino-passes-legislature-more-education-funds-toward-monrovia-and-25th-district/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/pencil-1486278_1920-350x197.jpg" alt="Portantino Passes Legislature, More Education Funds Toward Monrovia and 25th District" width="350" height="197" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/school-and-education/portantino-passes-legislature-more-education-funds-toward-monrovia-and-25th-district/">Portantino Passes Legislature, More Education Funds Toward Monrovia and 25th District</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/school-and-education/institute-educational-advancement-serving-needs-gifted-children/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/1-6-350x262.jpg" alt="Institute for Educational Advancement Serving the Needs of Gifted Children" width="350" height="262" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/school-and-education/institute-educational-advancement-serving-needs-gifted-children/">Institute for Educational Advancement Serving the Needs of Gifted Children</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/school-and-education/monrovia-unified-conferred-diplomas-400-grads/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/061317_MUSD_GRADS1-350x233.jpg" alt="Monrovia Unified Conferred Diplomas to Over 400 Grads" width="350" height="233" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/school-and-education/monrovia-unified-conferred-diplomas-400-grads/">Monrovia Unified Conferred Diplomas to Over 400 Grads</a></h6>
								</li></ul></div>
</li>
<li id="menu-item-21110" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/entertainment/">Arts &#038; Entertainment</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/entertainment/monrovias-rose-leaf-ragtime-club-hosts-musical-get-together/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/ragtime-piano-350x233.jpg" alt="Monrovia’s Rose Leaf Ragtime Club Hosts Musical Get-Together" width="350" height="233" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/entertainment/monrovias-rose-leaf-ragtime-club-hosts-musical-get-together/">Monrovia’s Rose Leaf Ragtime Club Hosts Musical Get-Together</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/entertainment/inaugural-media-creators-space-slated-may-25/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/04/media-creators-featured-350x263.png" alt="Inaugural ‘Media Creators Space’ Slated May 25" width="350" height="263" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/entertainment/inaugural-media-creators-space-slated-may-25/">Inaugural ‘Media Creators Space’ Slated May 25</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/entertainment/cinco-de-mayo-party-at-the-rose/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/04/1-2-350x109.jpg" alt="Cinco De Mayo Party At The Rose" width="350" height="109" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/entertainment/cinco-de-mayo-party-at-the-rose/">Cinco De Mayo Party At The Rose</a></h6>
								</li></ul></div>
</li>
<li id="menu-item-21122" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/sports-entertainment/">Sports</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/sports-entertainment/5-reasons-why-to-attend-football-clinics/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/stadium-1054510_960_720-350x263.jpg" alt="5 Reasons Why To Attend Football Clinics" width="350" height="263" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/sports-entertainment/5-reasons-why-to-attend-football-clinics/">5 Reasons Why To Attend Football Clinics</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/sports-entertainment/lucas-oil-pro-motocross-championship-highlights-fmf-glen-helen-national/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/05/DSC_1685-350x232.jpg" alt="Lucas Oil Pro Motocross Championship Highlights: FMF Glen Helen National" width="350" height="232" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/sports-entertainment/lucas-oil-pro-motocross-championship-highlights-fmf-glen-helen-national/">Lucas Oil Pro Motocross Championship Highlights: FMF Glen Helen National</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/sports-entertainment/monrovia-softball-eliminated-paramount/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/05/4-350x234.jpg" alt="Monrovia Softball Eliminated by Paramount" width="350" height="234" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/sports-entertainment/monrovia-softball-eliminated-paramount/">Monrovia Softball Eliminated by Paramount</a></h6>
								</li></ul></div>
</li>
<li id="menu-item-36800" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/calendar/">calendar</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/calendar/june-22-28/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/vertical-wine-tasting-350x263.jpg" alt="June 22 – 28" width="350" height="263" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/calendar/june-22-28/">June 22 – 28</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/calendar/june-15-june-21/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/1-5-350x234.jpg" alt="June 15 – June 21" width="350" height="234" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/calendar/june-15-june-21/">June 15 – June 21</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/calendar/june-8-15/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/beer-350x263.jpg" alt="June 8 – 15" width="350" height="263" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/calendar/june-8-15/">June 8 – 15</a></h6>
								</li></ul></div>
</li>
<li id="menu-item-36803" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/millennial-feed/">Millennial Feed</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/millennial-feed/7-formalities-millennials-forgo-workplace/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Screen-Shot-2017-06-20-at-9.52.21-AM-350x199.png" alt="7 Formalities Millennials Forgo in the Workplace" width="350" height="199" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/millennial-feed/7-formalities-millennials-forgo-workplace/">7 Formalities Millennials Forgo in the Workplace</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/millennial-feed/whytosmilewithamillennialonnationalselfieday/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/IMG_8849-350x233.jpg" alt="Why to Smile With a Millennial on National Selfie Day" width="350" height="233" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/millennial-feed/whytosmilewithamillennialonnationalselfieday/">Why to Smile With a Millennial on National Selfie Day</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/millennial-feed/why-millennials-feel-the-need-to-share-everything/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/web-shocked-Millennials-350x201.png" alt="Why Millennials Feel the Need to Share Everything" width="350" height="201" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/millennial-feed/why-millennials-feel-the-need-to-share-everything/">Why Millennials Feel the Need to Share Everything</a></h6>
								</li></ul></div>
</li>
<li id="menu-item-36801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.monroviaweekly.com/category/lifestyle/">Lifestyle</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/lifestyle/travel/summer-along-californias-central-coast-2/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/web-beach-350x162.jpg" alt="Summer Along California&#8217;s Central Coast" width="350" height="162" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/lifestyle/travel/summer-along-californias-central-coast-2/">Summer Along California&#8217;s Central Coast</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/lifestyle/dining-delights/10th-annual-uncorked-event-race-track-saturday-features-monrovia-restaurants/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/1-2-350x233.jpg" alt="10th Annual “Uncorked” Wine and Food Event at Race Track This Saturday; Features Monrovia Restaurants" width="350" height="233" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/lifestyle/dining-delights/10th-annual-uncorked-event-race-track-saturday-features-monrovia-restaurants/">10th Annual “Uncorked” Wine and Food Event at Race Track This Saturday; Features Monrovia Restaurants</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/lifestyle/travel/vevey-a-pearl-on-the-swiss-riviera/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/web-lavaux-pic-350x214.jpg" alt="Vevey: A Pearl on the Swiss Riviera" width="350" height="214" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/lifestyle/travel/vevey-a-pearl-on-the-swiss-riviera/">Vevey: A Pearl on the Swiss Riviera</a></h6>
								</li></ul>
<ul class="sub-menu">
	<li id="menu-item-21112" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/lifestyle/dining-delights/">Dining Delights</a></li>
	<li id="menu-item-36802" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/lifestyle/travel/">Travel</a></li>
	<li id="menu-item-26089" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/lifestyle/health-fitness/">Health &#038; Fitness</a></li>
</ul>
</div>
</li>
<li id="menu-item-36805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.monroviaweekly.com/category/opinion/">Opinion</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/opinion/columns/smart-women-smart-money-61517-issue/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/broken-piggy-bank-1472485404YoO-1024x683-350x233.jpg" alt="Smart Women, Smart Money (6/15/17 Issue)" width="350" height="233" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/opinion/columns/smart-women-smart-money-61517-issue/">Smart Women, Smart Money (6/15/17 Issue)</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/opinion/letter-to-the-editor/benny-bears-adventures-on-fathers-day/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/teddy-1338895_1920-1024x681-350x233.jpg" alt="Benny Bear’s Adventures on Father’s Day" width="350" height="233" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/opinion/letter-to-the-editor/benny-bears-adventures-on-fathers-day/">Benny Bear’s Adventures on Father’s Day</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/opinion/columns/cat-of-the-week-morris/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Morris-Blank.jpeg" alt="Cat of The Week: Morris" width="320" height="214" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/opinion/columns/cat-of-the-week-morris/">Cat of The Week: Morris</a></h6>
								</li></ul>
<ul class="sub-menu">
	<li id="menu-item-36806" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/opinion/columns/">Columns</a></li>
	<li id="menu-item-36807" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/opinion/letter-to-the-editor/">Letters to the Editor</a></li>
</ul>
</div>
</li>
<li id="menu-item-36808" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="http://www.monroviaweekly.com/category/community/">Community</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer-350x233.jpg" alt="Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#8217;" width="350" height="233" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/">Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#8217;</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/community/old-town-report-62217/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Monrovia-lights-350x155.jpg" alt="Old Town Report 6/22/17" width="350" height="155" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/community/old-town-report-62217/">Old Town Report 6/22/17</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/community/home-invasionbear/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/no-CRI-bear-cubs-350x263.jpg" alt="Home Invasion…BEAR" width="350" height="263" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/community/home-invasionbear/">Home Invasion…BEAR</a></h6>
								</li></ul></div>
</li>
<li id="menu-item-21118" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/obituaries/">Obituaries</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/obituaries/a-heavenly-departure-for-wessie-mae-dillon-1924-2017/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/04/feature-jesses-mom-350x315.jpg" alt="A Heavenly Departure for Wessie Mae Dillon (1924 – 2017)" width="350" height="315" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/obituaries/a-heavenly-departure-for-wessie-mae-dillon-1924-2017/">A Heavenly Departure for Wessie Mae Dillon (1924 – 2017)</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/obituaries/services-set-lisa-magno/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2016/12/lisa-magno-column-350x498.jpg" alt="A Deliberate Life – Lisa Magno Marino" width="350" height="498" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/obituaries/services-set-lisa-magno/">A Deliberate Life – Lisa Magno Marino</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/obituaries/services-are-set-for-retired-fire-captain-john-rooks/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2016/08/1-22-350x437.jpg" alt="Services Are Set for Retired Fire Captain John Rooks" width="350" height="437" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/obituaries/services-are-set-for-retired-fire-captain-john-rooks/">Services Are Set for Retired Fire Captain John Rooks</a></h6>
								</li></ul></div>
</li>
<li id="menu-item-36809" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.monroviaweekly.com/category/special-sections/">Special Sections</a><div class="sub-menu mega-menu "><ul class="mega-menu-posts">
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/special-sections/2017-summer-camps-education-guide/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/03/2017_03_23_SUMMER-CAMPS-ISSUE-cover-350x446.jpg" alt="2017 Summer Camps Education Guide" width="350" height="446" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/special-sections/2017-summer-camps-education-guide/">2017 Summer Camps Education Guide</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/special-sections/spring-arts-entertainment-3917/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/03/2017_03_09_BMI_Spring-Arts-2017-1-350x445.jpg" alt="Spring Arts &#038; Entertainment – 3/9/17" width="350" height="445" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/special-sections/spring-arts-entertainment-3917/">Spring Arts &#038; Entertainment – 3/9/17</a></h6>
								</li>
								<li>
									<div class="thumbnail">
										<a href="http://www.monroviaweekly.com/special-sections/catholic-schools-week/"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/01/2017_01_26_BMI_CatholicSchoolsWeekPG1-350x445.jpg" alt="Catholic Schools Week" width="350" height="445" /></a>
									</div>
									<h6><a href="http://www.monroviaweekly.com/special-sections/catholic-schools-week/">Catholic Schools Week</a></h6>
								</li></ul></div>
</li>
<li id="menu-item-36804" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://local.beaconmedianews.com/">Neighborhood Ads</a></li>
<li id="menu-item-37158" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.indeed.com/jobs?q=&amp;l=Monrovia%2C+CA&amp;radius=0">Local Jobs</a></li>
			</ul>
			
	      </nav>
	      
      </header>
      
            
      
      <!--1200px Grid-->
      <div id="cn_content" class="container row">
          
          <div id="breadcrumbs">
	         <div class="navi"><i class="fa fa-home"></i><a href="http://www.monroviaweekly.com/">Home</a> <span class="sep">&raquo;</span> <span class="current">Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#8217;</span></div> 
	         	         <div class="share">
		           <a href="https://www.facebook.com/sharer/sharer.php?u=http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" target="_blank" class="facebook"><i class="fa fa-facebook"></i></a>
		        <a href="http://twitter.com/share?text=Monrovian+Larry+Spicer+Named+41st+Assembly+District%E2%80%99s+%E2%80%98Veteran+of+the+Year%26%238217%3B&amp;url=http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" target="_blank" class="twitter"><i class="fa fa-twitter"></i></a>
		        <a href="https://plus.google.com/share?url=http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" target="_blank" class="gplus"><i class="fa fa-google-plus"></i></a>
		        <a href="https://pinterest.com/pin/create/button/?media=http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer.jpg&amp;description=Monrovian+Larry+Spicer+Named+41st+Assembly+District%E2%80%99s+%E2%80%98Veteran+of+the+Year%26%238217%3B&amp;url=http%3A%2F%2Fwww.monroviaweekly.com%2Fcommunity%2Fmonrovian-larry-spicer-named-41st-assembly-districts-veteran-year%2F" target="_blank" class="pinterest"><i class="fa fa-pinterest"></i></a>
		        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;title=Monrovian+Larry+Spicer+Named+41st+Assembly+District%E2%80%99s+%E2%80%98Veteran+of+the+Year%26%238217%3B&amp;source=http%3A%2F%2Fwww.monroviaweekly.com%2Fcommunity%2Fmonrovian-larry-spicer-named-41st-assembly-districts-veteran-year%2F&amp;url=http%3A%2F%2Fwww.monroviaweekly.com%2Fcommunity%2Fmonrovian-larry-spicer-named-41st-assembly-districts-veteran-year%2F" target="_blank" class="linkedin"><i class="fa fa-linkedin"></i></a>
	         </div>
	                   </div>
          
	      <!--Main Content-->
	      <div id="main" class="twelve columns">
	        <div class="standard_blog">          	                  
	                  
                     
		<!---Posts-->
				<article class="post-37793 post type-post status-publish format-standard has-post-thumbnail hentry category-community">
				
		<div class="entry-body">
				  <span class="category"><a href="http://www.monroviaweekly.com/category/community/" rel="category tag">Community</a></span>
		  		  <h4 class="entry-title">Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#8217;</h4>
		  		  <span class="title-divider"></span>
				  
		  <div class="entry-content">
		    <div class='shareaholic-canvas' data-app-id='22752547' data-app='share_buttons' data-title='Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#039;' data-link='http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/' data-summary=''></div><div id="attachment_37795" style="width: 360px" class="wp-caption aligncenter"><img class="wp-image-37795 size-medium" src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer-350x233.jpg" alt="- Courtesy photo" width="350" height="233" srcset="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer-350x233.jpg 350w, http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer-150x100.jpg 150w, http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer-500x333.jpg 500w, http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer-300x200.jpg 300w, http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer-610x407.jpg 610w, http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer-600x400.jpg 600w" sizes="(max-width: 350px) 100vw, 350px" /><p class="wp-caption-text">“I am pleased to recognize Council member Larry Spicer as the 41st Assembly District’s Veteran of the Year,” said Assembly member Holden. &#8211; Courtesy photo</p></div>
<p>For the 41st Assembly District’s 2017 “Veteran of the Year,” Assembly member Chris Holden has chosen to honor Monrovia Council member Larry J. Spicer, a veteran who served in the U.S. Army from 1973 to 1994.</p>
<p>“I am pleased to recognize Council member Larry Spicer as the 41st Assembly District’s Veteran of the Year,” said Assembly member Holden (AD – 41). “After serving in our country’s armed forces, Larry continues to make a positive impact as council member, community leader and volunteer.”</p>
<p>Larry Spicer joined the U.S Army in August of 1973 after graduating from Monrovia High School. After Basic Training and Advance Individual Training (Logistics) at Ford Ord, California he was assigned to duty stations at Fort Lewis Washington, Fort Carson Colorado, Fort Sill Oklahoma, Korea and Germany.</p>
<p>While in the US Army, Spicer continued his education by taking such courses on leadership development, logistics management, accounting and procurement. He retired in 1994 after 21 years of dedicated service to his country. His rank at retirement was Sergeant First Class.</p>
<p>Spicer is currently an active member of the American Legion and the Veterans of Foreign Wars. He was recently reelected to serve a second term as Council member in his hometown of Monrovia. In addition to serving in that capacity and other volunteer positions in the City of Monrovia, Los Angeles County area, and as a “White Suit” volunteer for the Tournament of Roses, he also spends many hours helping veterans get their benefits.</p>
<span class="cp-load-after-post"></span><div id="fb_share_1" style="clear:right; float: right; margin-left: 10px; margin-top:11px;"><a name="fb_share" type="box_count" share_url="http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" href="http://www.facebook.com/sharer.php">Share</a></div><div><script src="http://static.ak.fbcdn.net/connect.php/js/FB.Share" type="text/javascript"></script></div><div class='shareaholic-canvas' data-app-id='22752543' data-app='share_buttons' data-title='Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#039;' data-link='http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/' data-summary=''></div><div class='shareaholic-canvas' data-app-id='22752551' data-app='recommendations' data-title='Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#039;' data-link='http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/' data-summary=''></div>		    
		                <div class="clear"></div>
		  </div>
		  <footer class="entry-tools">
		    <span>June 23, 2017</span>		    
		    
		    		    <div class="share"> <a href="https://www.facebook.com/sharer/sharer.php?u=http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" target="_blank" class="facebook"><i class="fa fa-facebook"></i></a>
		        <a href="http://twitter.com/share?text=Monrovian+Larry+Spicer+Named+41st+Assembly+District%E2%80%99s+%E2%80%98Veteran+of+the+Year%26%238217%3B&amp;url=http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" target="_blank" class="twitter"><i class="fa fa-twitter"></i></a>
		        <a href="https://plus.google.com/share?url=http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" target="_blank" class="gplus"><i class="fa fa-google-plus"></i></a>
		        <a href="https://pinterest.com/pin/create/button/?media=http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer.jpg&amp;description=Monrovian+Larry+Spicer+Named+41st+Assembly+District%E2%80%99s+%E2%80%98Veteran+of+the+Year%26%238217%3B&amp;url=http%3A%2F%2Fwww.monroviaweekly.com%2Fcommunity%2Fmonrovian-larry-spicer-named-41st-assembly-districts-veteran-year%2F" target="_blank" class="pinterest"><i class="fa fa-pinterest"></i></a>
		        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;title=Monrovian+Larry+Spicer+Named+41st+Assembly+District%E2%80%99s+%E2%80%98Veteran+of+the+Year%26%238217%3B&amp;source=http%3A%2F%2Fwww.monroviaweekly.com%2Fcommunity%2Fmonrovian-larry-spicer-named-41st-assembly-districts-veteran-year%2F&amp;url=http%3A%2F%2Fwww.monroviaweekly.com%2Fcommunity%2Fmonrovian-larry-spicer-named-41st-assembly-districts-veteran-year%2F" target="_blank" class="linkedin"><i class="fa fa-linkedin"></i></a>
</div>
		    		  </footer>
		 </div>
		</article> 
	    
				
		<!--Author-->
		<section id="author_vcard">
		<h3 class="author-title section-title">About Author</h3>
		<a class="avatar" href="http://www.monroviaweekly.com/author/staff/"><img alt='' src='http://2.gravatar.com/avatar/2fc2d371b7e8b3100fe37f52b0fcc0cd?s=80&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/2fc2d371b7e8b3100fe37f52b0fcc0cd?s=160&amp;d=mm&amp;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /></a>
		<p><strong>Staff</strong>
		 
		<p><span class="social_icons"></span></p>
		</p>
		
	
		<br class="clearfix" />
		</section>    
				
		<!--Prev / Next-->
		<div class="post_navi">           
		<div class="alignleft item"><i class="fa fa-angle-left"></i><a href="http://www.monroviaweekly.com/current-news/crime/couple-outstanding-arrest-warrants-nabbed-auto-burglary-arcadia/" rel="prev">Couple With Outstanding Arrest Warrants Nabbed for Auto Burglary in Arcadia</a></div>		 
		</div>
		
				
		<!--Comment-->
		
<!-- You can start editing here. -->

	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.monroviaweekly.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='37793' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1aa0a3e29b" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="246"/></p>			</form>
			</div><!-- #respond -->
	                  
		    </div>
	      </div>
	      
	            
          <!--SideBar-->
	      <aside id="sidebar" class="four columns omega">
	         <div id="alaya_recent_posts-3" class="widget widget_alaya_recent_posts"><h6 class="widget_title">SEE WHAT&#8217;S NEW</h6><ul class="post_list"><li class="post-list-37793"><a href="http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" class="thumbnail"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Holden_and_Spicer-150x100.jpg" alt="Monrovian Larry Spicer Named 41st Assembly District’s ‘Veteran of the Year&#039;" /></a><a href="http://www.monroviaweekly.com/community/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year/" class="post_title">Monrovian Larry Spicer Named 41st Assembly Di...</a><p>June 23, 2017</p><div class="clear"></div></li><li class="post-list-37886"><a href="http://www.monroviaweekly.com/current-news/crime/couple-outstanding-arrest-warrants-nabbed-auto-burglary-arcadia/" class="thumbnail"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Beyers-Duarte-150x90.jpg" alt="Couple With Outstanding Arrest Warrants Nabbed for Auto Burglary in Arcadia" /></a><a href="http://www.monroviaweekly.com/current-news/crime/couple-outstanding-arrest-warrants-nabbed-auto-burglary-arcadia/" class="post_title">Couple With Outstanding Arrest Warrants Nabbe...</a><p>June 22, 2017</p><div class="clear"></div></li><li class="post-list-37875"><a href="http://www.monroviaweekly.com/current-news/monrovia-community-media-foothills-continue-managing-kgem-now/" class="thumbnail"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Joey-Delgado_Miller-1-150x226.jpg" alt="Monrovia Community Media of the Foothills to Continue Managing KGEM, For Now" /></a><a href="http://www.monroviaweekly.com/current-news/monrovia-community-media-foothills-continue-managing-kgem-now/" class="post_title">Monrovia Community Media of the Foothills to ...</a><p>June 22, 2017</p><div class="clear"></div></li><li class="post-list-37858"><a href="http://www.monroviaweekly.com/arts-entertainment/rehearsals-begin-king-monrovia-many-locals-production/" class="thumbnail"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Photo-7-150x100.jpg" alt="Rehearsals Begin for The King and I in Monrovia; Many Locals in Production" /></a><a href="http://www.monroviaweekly.com/arts-entertainment/rehearsals-begin-king-monrovia-many-locals-production/" class="post_title">Rehearsals Begin for The King and I in Monrov...</a><p>June 22, 2017</p><div class="clear"></div></li><li class="post-list-37882"><a href="http://www.monroviaweekly.com/business/small-business-committee-approves-rep-chu-bill-to-increase-small-business-investment/" class="thumbnail"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Judy-Chu-1024x680-150x100.jpg" alt="Small Business Committee Approves Rep. Chu Bill to Increase Small Business Investment" /></a><a href="http://www.monroviaweekly.com/business/small-business-committee-approves-rep-chu-bill-to-increase-small-business-investment/" class="post_title">Small Business Committee Approves Rep. Chu Bi...</a><p>June 22, 2017</p><div class="clear"></div></li></ul></div><div id="metaslider_widget-5" class="widget widget_metaslider_widget"><!-- meta slider -->
<div style="max-width: 300px;" class="metaslider metaslider-flex metaslider-17500 ml-slider nav-hidden">
    
    <div id="metaslider_container_17500">
        <div id="metaslider_17500" class="flexslider">
            <ul class="slides">
                <li style="display: block; width: 100%;" class="slide-37180 ms-image"><a href="http://www.creativityinliving.com/" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/05/6.6.17_TOP-NOTCH-300x250-1.jpg" height="250" width="300" alt="" class="slider-17500 slide-37180" /></a></li>
                <li style="display: none; width: 100%;" class="slide-25149 ms-image"><a href="http://www.teamnuvision.net/" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2016/05/2015_06_05_Carsten-Phillips-300x250-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-25149" /></a></li>
                <li style="display: none; width: 100%;" class="slide-37829 ms-image"><a href="http://www.drdomotoranimalhouse.com/ " target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/12.14.17_Animal-House-Vet-Hosp-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-37829" /></a><div class="caption-wrap"><div class="caption">Share</div></div></li>
                <li style="display: none; width: 100%;" class="slide-28191 ms-image"><a href="http://www.ameripriseadvisors.com/jean.d.koehler/" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2016/11/2016_11_17_Ameriprise-Financial-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-28191" /></a></li>
                <li style="display: none; width: 100%;" class="slide-30537 ms-image"><a href="http://www.centuryrooter.com" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/03/2017_03_16_Century-Rooter-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-30537" /></a></li>
                <li style="display: none; width: 100%;" class="slide-37667 ms-image"><a href="http://TheAAR.com" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/6.28.17_Arcadia-Association-of-Realtors-300X250.jpg" height="250" width="300" alt="" class="slider-17500 slide-37667" /></a><div class="caption-wrap"><div class="caption">Share</div></div></li>
                <li style="display: none; width: 100%;" class="slide-36849 ms-image"><a href="http://www.crowncityloan.com" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/05/2017_05_04_-Crown-City-Loan-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-36849" /></a><div class="caption-wrap"><div class="caption">Share</div></div></li>
                <li style="display: none; width: 100%;" class="slide-37500 ms-image"><a href="http://www.decaroauctions.com/" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/2017_06_22_Decaro-Auctions-300x250.png" height="250" width="300" alt="" class="slider-17500 slide-37500" /></a><div class="caption-wrap"><div class="caption">Share</div></div></li>
                <li style="display: none; width: 100%;" class="slide-37669 ms-image"><a href="http://mtsierracollege.edu" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/6.28.17_Mt-Sierra-College-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-37669" /></a><div class="caption-wrap"><div class="caption">Share</div></div></li>
                <li style="display: none; width: 100%;" class="slide-37666 ms-image"><a href="https://www.arcadiaca.gov/government/city-departments/public-works-services/environmental-services/stormwater-industrial-waste" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/7.16.17_City-of-Arcadia-Check-Number-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-37666" /></a><div class="caption-wrap"><div class="caption">Share</div></div></li>
                <li style="display: none; width: 100%;" class="slide-37665 ms-image"><a href="https://www.archetypebeardcompany.com/" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/6.30.17_Archetype-Beard-Co-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-37665" /></a><div class="caption-wrap"><div class="caption">Share</div></div></li>
                <li style="display: none; width: 100%;" class="slide-37830 ms-image"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/6.24.17-CA-Mission-Inn-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-37830" /><div class="caption-wrap"><div class="caption">Share</div></div></li>
                <li style="display: none; width: 100%;" class="slide-37499 ms-image"><a href="http://www.decaroauctions.com/" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/2017_06_22_Decaro-Auctions-2-300x250.png" height="250" width="300" alt="" class="slider-17500 slide-37499" /></a><div class="caption-wrap"><div class="caption">Share</div></div></li>
                <li style="display: none; width: 100%;" class="slide-24220 ms-image"><a href="https://gigglefiber.com/" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2016/03/2016_03_18_Giggle-Fiber-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-24220" /></a></li>
                <li style="display: none; width: 100%;" class="slide-37502 ms-image"><a href="https://gigglefiber.com/" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/Giggle-Fiber_May2017-300x250-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-37502" /></a><div class="caption-wrap"><div class="caption">Share</div></div></li>
                <li style="display: none; width: 100%;" class="slide-29629 ms-image"><a href="http://www.sbroyleslaw.com/" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/02/2017_02_23_Samuel-G-Broyles-Law-Offices-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-29629" /></a></li>
                <li style="display: none; width: 100%;" class="slide-37504 ms-image"><a href="http://www.altadenalibrary.org/" target="_blank"><img src="http://www.monroviaweekly.com/wp-content/uploads/2017/06/2015_12_03_ALtadena-Library-300x250-GENERIC-AD-300x250.jpg" height="250" width="300" alt="" class="slider-17500 slide-37504" /></a><div class="caption-wrap"><div class="caption">Share</div></div></li>
            </ul>
        </div>
        
    </div>
    <script type="text/javascript">
        var metaslider_17500 = function($) {
            $('#metaslider_17500').flexslider({ 
                slideshowSpeed:5000,
                animation:"fade",
                controlNav:false,
                directionNav:true,
                pauseOnHover:true,
                direction:"horizontal",
                reverse:false,
                animationSpeed:500,
                prevText:"&lt;",
                nextText:"&gt;",
                slideshow:true
            });
        };
        var timer_metaslider_17500 = function() {
            var slider = !window.jQuery ? window.setTimeout(timer_metaslider_17500, 100) : !jQuery.isReady ? window.setTimeout(timer_metaslider_17500, 1) : metaslider_17500(window.jQuery);
        };
        timer_metaslider_17500();
    </script>
</div>
<!--// meta slider--></div><div id="text-488852904" class="widget widget_text"><h6 class="widget_title">STAY CONNECTED</h6>			<div class="textwidget"></div>
		</div>	      </aside>	      
      </div>      <div id="bottom_widget">
         <div class="container">
	       <section class="four columns">
	        <div id="text-488852905" class="widget widget_text"><h6 class="widget_title">Local Resources</h6>			<div class="textwidget"><h6 style="font-size:14px; text-align: left;"><a href="http://www.monroviacc.com/">Chamber of Commerce</a></h6>

<h6 style="font-size:14px; text-align: left;"><a href="http://www.cityofmonrovia.org/recreation/page/seniors">Citizen Service Center</a></h6>

<h6 style="font-size:14px; text-align: left;"><a href="http://www.cityofmonrovia.org/citycouncil">City Hall</a></h6>

<h6 style="font-size:14px; text-align: left;"><a href="http://www.cityofmonrovia.org/police">Monrovia Police Department</a></h6>

<h6 style="font-size:14px; text-align: left;"><a href="http://www.cityofmonrovia.org/police">Monrovia Fire Department</a></h6> 

<h6 style="font-size:14px; text-align: left;"><a href="http://www.cityofmonrovia.org/citycouncil/page/meet-city-council">Your City Council</a></h6> </div>
		</div>	      </section>
	      
	      <section class="four columns">
	          <div id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><h6 class="widget_title">Join the Community</h6><script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- MailChimp for WordPress v4.1.4 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-37840" method="post" data-id="37840" data-name="Join the Community" ><div class="mc4wp-form-fields"><p>
    <label>First and Last Name</label>
</p>
   <p>
     <input type="text" name="FNAME">
   </p> 
<p>
    <label>Email *</label>
</p>
<p>
  <input type="email" name="EMAIL" required="">
</p>
<p>
</p>
<p>
    <input type="submit" value="Subscribe">
</p><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></div><input type="hidden" name="_mc4wp_timestamp" value="1498226555" /><input type="hidden" name="_mc4wp_form_id" value="37840" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /></div><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin --></div>	      </section>
	      
	      <section class="four columns">
	       <div id="text-488852902" class="widget widget_text"><h6 class="widget_title">Monrovia Weekly</h6>			<div class="textwidget"><h6 style="font-size:14px; text-align: left;"><a href="http://www.monroviaweekly.com/about-us/">Who We Are</a></h6>
<h6 style="font-size:14px; text-align: left;"><a href="http://www.monroviaweekly.com/meet-the-team/">Meet the Team</a></h6>
<h6 style="font-size:14px; text-align: left;"><a href="http://www.monroviaweekly.com/contact/">Contact Us</a></h6>
<h6 style="font-size:14px; text-align: left;"><a href="http://www.monroviaweekly.com/category/print-edition/">E-Edition</a></h6>
<h6 style="font-size:14px; text-align: left;"><a href="http://www.beaconmedianews.com/">Corporate Site</a></h6></div>
		</div>	      </section>
	      	    
	      <section class="four columns omega">
	      <div id="text-488852903" class="widget widget_text"><h6 class="widget_title">Follow Us On Instagram</h6>			<div class="textwidget"><div id="sb_instagram" class="sbi sbi_fixed_height  sbi_col_3 sbi_width_resp" style="width:300px; height:300px; padding-bottom: 10px; " data-id="1641916070" data-num="9" data-res="auto" data-cols="3" data-options='{&quot;sortby&quot;: &quot;none&quot;, &quot;headercolor&quot;: &quot;&quot;, &quot;imagepadding&quot;: &quot;5&quot;}'><div class="sb_instagram_header" style="padding: 10px; padding-bottom: 0;"></div><div id="sbi_images" style="padding: 5px;"><div class="sbi_loader fa-spin"></div></div><div id="sbi_load"><a class="sbi_load_btn" href="javascript:void(0);" style="background: #6b6b6b; ">Load More...</a><div class="sbi_follow_btn"><a href="http://instagram.com/" style="background: #6b6b6b; " target="_blank"><i class="fa fa-instagram"></i>Follow on Instagram</a></div></div></div></div>
		</div>	      </section>
       </div>
     
    </div> <!--//Bottom widgets-->      
      <!--Footer-->
      <footer id="footer">
        <div class="container">
	     <div class="copyright eight columns">
		                      ©2017 Beacon Media News. All Rights Reserved		      
	     </div>
	     <div class="footer_menu eight columns">
		    <ul id="menu-footer-menu-1" class="footer_menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37140"><a href="http://www.monroviaweekly.com/wp-admin">Log In</a></li>
</ul>	     
		 </div>
        </div>
      </footer>
      
              
      <!--Popup-->
      <div id="popup_window" class="popup_content">
        <a href="javascript:void(0)" class="close_popup"><i class="fa fa-close"></i></a>
	    
	    	    <div id="popup_search" class="popup_content">
		    <h3>Searching</h3>
		    <div class="content container">
			  <form action="http://www.monroviaweekly.com/" method="get" name="searchform" class="popup_form">
			      <div class="eight columns alpha">
				    <input type="text" name="s" class="u-full-width" placeholder="Keyword" />
			      </div>
			      <div class="four columns alpha omega">
				  	<input type="submit" name="search_button" class="button-primary" value="Search" />
			      </div>
			  </form>
		    </div>
	     </div>
	     	    
	     
	     	     
      </div>
      <div class="page_mask"></div>        
      </div><!--//body container-->
      
      <a href="javascript:void(0);" class="up_btn" id="backtoTop"><i class="fa fa-arrow-up"></i></a>
      
            	            <script type="text/javascript" id="modal">
				jQuery(window).on( 'load', function(){
					startclock();
				});
				function stopclock (){
				  if(timerRunning) clearTimeout(timerID);
				  timerRunning = false;
				  document.cookie="time=0";
				}
				function showtime () {
				  var now = new Date();
				  var my = now.getTime() ;
				  now = new Date(my-diffms) ;
				  document.cookie="time="+now.toLocaleString();
				  timerID = setTimeout('showtime()',10000);
				  timerRunning = true;
				}
				function startclock () {
				  stopclock();
				  showtime();
				}
				var timerID = null;
				var timerRunning = false;
				var x = new Date() ;
				var now = x.getTime() ;
				var gmt = 1498226555 * 1000 ;
				var diffms = (now - gmt) ;
				</script>
	            	            <script type="text/javascript" id="info-bar">
				jQuery(window).on( 'load', function(){
					startclock();
				});
				function stopclock (){
				  if(timerRunning) clearTimeout(timerID);
				  timerRunning = false;
				  document.cookie="time=0";
				}
				function showtime () {
				  var now = new Date();
				  var my = now.getTime() ;
				  now = new Date(my-diffms) ;
				  document.cookie="time="+now.toLocaleString();
				  timerID = setTimeout('showtime()',10000);
				  timerRunning = true;
				}
				function startclock () {
				  stopclock();
				  showtime();
				}
				var timerID = null;
				var timerRunning = false;
				var x = new Date() ;
				var now = x.getTime() ;
				var gmt = 1498226555 * 1000 ;
				var diffms = (now - gmt) ;
				</script>
	            	            <script type="text/javascript" id="slidein">
				jQuery(window).on( 'load', function(){
					startclock();
				});
				function stopclock (){
				  if(timerRunning) clearTimeout(timerID);
				  timerRunning = false;
				  document.cookie="time=0";
				}

				function showtime () {
				  var now = new Date();
				  var my = now.getTime() ;
				  now = new Date(my-diffms) ;
				  document.cookie="time="+now.toLocaleString();
				  timerID = setTimeout('showtime()',10000);
				  timerRunning = true;
				}

				function startclock () {
				  stopclock();
				  showtime();
				}
				var timerID = null;
				var timerRunning = false;
				var x = new Date() ;
				var now = x.getTime() ;
				var gmt = 1498226555 * 1000 ;
				var diffms = (now - gmt) ;
				</script>
	            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script><script type="text/javascript">(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.2'></script>
<link rel='stylesheet' id='metaslider-flex-slider-css'  href='http://www.monroviaweekly.com/wp-content/plugins/ml-slider/assets/sliders/flexslider/flexslider.css?ver=3.5.1' type='text/css' media='all' property='stylesheet' />
<link rel='stylesheet' id='metaslider-public-css'  href='http://www.monroviaweekly.com/wp-content/plugins/ml-slider/assets/metaslider/public.css?ver=3.5.1' type='text/css' media='all' property='stylesheet' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.monroviaweekly.com\/wp-json\/","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"1641912769.3a81a9f.6367607ae6cc46a793bda4e44be07bd0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.4.9'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var emailL10n = {"ajax_url":"http:\/\/www.monroviaweekly.com\/wp-admin\/admin-ajax.php","max_allowed":"5","text_error":"The Following Error Occurs:","text_name_invalid":"- Your Name is empty\/invalid","text_email_invalid":"- Your Email is empty\/invalid","text_remarks_invalid":"- Your Remarks is invalid","text_friend_names_empty":"- Friend Name(s) is empty","text_friend_name_invalid":"- Friend Name is empty\/invalid: ","text_max_friend_names_allowed":"- Maximum 5 Friend Names allowed","text_friend_emails_empty":"- Friend Email(s) is empty","text_friend_email_invalid":"- Friend Email is invalid: ","text_max_friend_emails_allowed":"- Maximum 5 Friend Emails allowed","text_friends_tally":"- Friend Name(s) count does not tally with Friend Email(s) count","text_image_verify_empty":"- Image Verification is empty"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/wp-email/email-js.js?ver=2.67.5'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/bloom/js/jquery.uniform.min.js?ver=1.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bloomSettings = {"ajaxurl":"http:\/\/www.monroviaweekly.com\/wp-admin\/admin-ajax.php","pageurl":"http:\/\/www.monroviaweekly.com\/community\/monrovian-larry-spicer-named-41st-assembly-districts-veteran-year\/","stats_nonce":"088fcd32c1","subscribe_nonce":"178c21934b"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/bloom/js/custom.js?ver=1.1.2'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/bloom/js/idle-timer.min.js?ver=1.1.2'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.sticky.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.easing.min.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.masonry.min.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.superfish.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.nicescroll.min.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.justifiedGallery.min.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/pushy.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/js_composer/assets/lib/bower/flexslider/jquery.flexslider-min.js?ver=5.1'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.flexloader.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.validate.min.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/send-mail.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.simpleWeather.min.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/swiper.jquery.min.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/jquery.hoverdelay.js'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/citynews.js'></script>
<script type='text/javascript'>
var comment_title="COMMENT ON THIS POST";
   var temperature_unit="f";
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajaxcomment = {"ajax_url":"http:\/\/www.monroviaweekly.com\/wp-admin\/admin-ajax.php","order":"asc","formpostion":"bottom"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/themes/citynews/assets/js/ajax-comment.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-includes/js/comment-reply.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/ml-slider/assets/sliders/flexslider/jquery.flexslider-min.js?ver=3.5.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.1.4'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='http://www.monroviaweekly.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.1.4'></script>
<![endif]-->
        <script type="text/javascript">
            function AI_responsive_widget() {
                jQuery('object.StefanoAI-youtube-responsive').each(function () {
                    jQuery(this).parent('.fluid-width-video-wrapper').removeClass('fluid-width-video-wrapper').removeAttr('style').css('width', '100%').css('display', 'block');
                    jQuery(this).children('.fluid-width-video-wrapper').removeClass('fluid-width-video-wrapper').removeAttr('style').css('width', '100%').css('display', 'block');
                    var width = jQuery(this).parent().innerWidth();
                    var maxwidth = jQuery(this).css('max-width').replace(/px/, '');
                    var pl = parseInt(jQuery(this).parent().css('padding-left').replace(/px/, ''));
                    var pr = parseInt(jQuery(this).parent().css('padding-right').replace(/px/, ''));
                    width = width - pl - pr;
                    if (maxwidth < width) {
                        width = maxwidth;
                    }
                    jQuery(this).css('width', width + "px");
                    jQuery(this).css('height', width / (16 / 9) + "px");
                    jQuery(this).find('iframe').css('width', width + "px");
                    jQuery(this).find('iframe').css('height', width / (16 / 9) + "px");
                });
            }
            if (typeof jQuery !== 'undefined') {
                jQuery(document).ready(function () {
                    var tag = document.createElement('script');
                    tag.src = "https://www.youtube.com/iframe_api";
                    var firstScriptTag = document.getElementsByTagName('script')[0];
                    firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);
                    AI_responsive_widget();
                });
                jQuery(window).resize(function () {
                    AI_responsive_widget();
                });
            }
                </script>
            </body>
</html>
<!-- Dynamic page generated in 1.588 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2017-06-23 07:02:35 -->

<!-- super cache -->